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1. Introduction

About this Manual

Intended Use of this Manual
• This manual describes the common use of the MAP Check 3 PC Software.

It is intended for the daily users and should be kept with the equipment for reference at all times.

Reservations
• This manual was written and illustrated using the best possible information available at the time of 

publication.
• Any differences between this manual and the software reflect improvements introduced after the 

publication of the manual.
• Changes, technical inaccuracies and typographic errors will be corrected in subsequent editions.
• As a part of our policy of continuous improvement, we reserve the right to alter design and 

specifications without further notice.

Important!

Safety and Use
To promote safety awareness you must read and understand the Safety Instructions delivered with the 
MAP Check 3 device before performing any installation, operation or maintenance of the device.
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Notes, cautions and warnings!
Throughout the manual notes, cautions, and warnings are indicated with various icons and written in bold 
like the example below:

CAUTION! Always replace a fuse with one of the same size and rating.

Explanation

NOTE! The operator should observe and/or act according to the information in order to 
obtain the best possible function of the equipment.

CAUTION! The operator must observe and/or act according to the information in order to 
avoid any mechanical or electrical damage to the equipment.

WARNING! The operator must observe and/or act according to the information in order to 
avoid any personnel injury.
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2. Installation of the Software

IMPORTANT! Please read the terms and conditions of the software license agreement on 
page 35 carefully before installation.

IMPORTANT! Install the software before the MAP Check 3 device is connected to the PC as 
it includes necessary device drivers.

NOTE! Earlier versions of the program must be removed prior to the installation. To remove 
program select Control Panel -> Add/Remove Programs -> MAP Check 3 PC Software.
Please note that database files will not be deleted automatically when uninstalling the 
program. To do so delete all files in the following folder:
C:\Program Files\PBI-Dansensor\Mc3PcApp\Database

• The installation CD starts automatically when inserted in the PC’s CD drive.
If not it can be started manually following the below procedure:
- From your computer’s desktop open My Computer.
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- In the appearing window locate the CD drive (labelled MAP Check 3), right-click the icon...

...and from the appearing drop-down menu select Open.

- Locate the file StartCD.exe and double-click it.
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- This will open the special application from where you can install the software and print a user guide.

- Click on the START button and then follow the directions to start the software installation.
• When installation starts...

• Click Accept and wait.
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• When the following screen appears...

...click Next to start the installation.
• In the appearing License Agreement window...

...click I Agree to accept the license agreement and then click Next.
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• In the Shortcut creation window...

...select your preferred shortcut and click Next.
• We recommend that you install the program in the folder proposed by the installer.

Click Next.
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• Click Next to start the installation.

• Click Continue Anyway.
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• When this window appears...

...click Close.
• The software has been successfully installed.
• Verify that an application short-cut has been placed on your desktop (if selected during installation).
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3. Using the Software

General

The easy-to-use MAP Check 3 PC Software enables the control of several MAP Check 3 units in a 
production environment.

The PC software makes it easy to create and manage products, to set up product measurement details 
and to monitor general device settings.

During the day all measurement data can continuously be transferred from the analyzer to the 
application’s database and at the end of the day all collected data can be exported for further analysis.

The following issues are described in this section:

• PC User/Login setup
• Device setup
• Products setup
• Management of measurement data
• Database maintenance
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Starting the application
To start the application simply double-click the MAP Check 3 PC Software icon on your desktop 
or select Start -> All Programs -> PBI-Dansensor -> MAP Check 3 PC Software.

The application starts and if a MAP Check 3 device has been connected the following message will 
appear:

Click Yes to start synchronization.

Login
To be able to perform any changes to the device settings, product setup or user setup, you must be 
logged in.
The default user must be used the first time at login. The default user has the following login properties:
User: administrator
Password: password

To log in click Login in the upper right hand corner. In the appearing login window...

...enter the required User and Password and click OK.

As indicated in the application’s lower left corner you are now logged in as administrator.

Now you are able to create one or more new users and set up different user rights if required. See 
"Application User Management" on page 21 for details.
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Application Overview

 File
The File menu holds the following item:

Exit Closes the application.

View
The View menu holds the following item:

Show measurements statistics Select if you want to show 
measurement statistics at the 
right side of the screen while 
working on the Measurements 
tab.

3 8 109 11421 5 6

7
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Settings
The Settings menu holds the following entries:

Language Select application language.

Options User login setup...
Create PC application users and set up different rights if 
required.
See "Application User Management" on page 21 for details.

Database setup...
Selection of database containing measurement data.
Either local database (default) or external SQL server.
See "Database Management" on page 24 for details on back-
up of databases.

Flow unit
Select flow read-out unit (l/min or SCFH)

Pressure unit
Select pressure read-out unit (bar or psi)

Remote data dump Run server on application startup
Select whether or not you want the Remote data dump 
function to start up automatically when launching the 
application. See "Remote Data Dump Function" on page 33 for 
details.

 Help
The Help menu holds the following entries:

Register After installation the program is valid for 30 days free of 
charge. At the end of the evaluation period the Registration 
window will appear.

To register enter License number and License key and press 
OK.

NOTE! Using the application beyond the evaluation 
period will not be possible.

NOTE! Be careful to distinguish between 0 (zero) 
and O (capital o) when entering License number 
and License key and to enter all - (hyphens) as 
well.
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About Displays the currently installed version of the software.

 Synchronize
Synchronization of the data on the currently selected tab with the connected device(s)
See "Data Synchronization" on page 20 for details.

 Login/Logout
Log in to the application to be able to perform any changes to the device settings or the product or user 
setups.

To change user first click Logout and then Login again.

 Not logged in/Logged in as...
Display of current login status.

 Measurements tab
Managing of measurement data - see "Measurement Data" on page 25 for details.

 Product list tab
Managing of products - see "Product Setup" on page 29 for details.

 Device list tab
Overview of and information about currently and previously connected devices - see "Device list" on 
page 31 for details.

 Remote data dump tab
Make settings for the Remote data dump function - see "Remote Data Dump Function" on page 33 for 
details.
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Data Synchronization

You can manually synchronize all data with any of the connected devices.
To do so follow procedure below:

• Click Synchronize in the upper right hand corner.
The Synchronization window will appear.

• The connected devices are shown with Device name and Serial number.
• In the Synchronize column select device(s) for which you want to perform the synchronization.
• In the Delete measurements column select whether or not you want to delete synchronized data from 

the currently selected device(s) after upload to the application.
• Click Sync.

• When synchronization has finished click Close.

NOTE! The PC software is the master. During synchronization any products differences will 
be overwritten on the devic(es).
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Application User Management
Several users can be created with various levels of application access rights.
The default user must be used the first time at login - see "Login" on page 16 for details. 

Create User
To create a new user and set up the respective user rights do the following:

1. Select Settings -> Options -> User login setup...
This will open the PC Users Setup window. 

2. Click New to create a new user.

A new user named User_X will be added to the users list.
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3. To edit user’s name place cursor in the Name field and change name to ex. QA Manager.

4. Select user’s access rights using the Access level drop-down menu, ex. Edit products and users. 

The corresponding user rights are listed in the User Rights section.

5. To create password click Click to change in the New password field.

Enter password information as required and click OK.

6. Click OK to close window.
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Edit/Delete User
To edit a user’s settings do the following:

• Select Settings -> Options -> User login setup...

• In the appearing PC Users Setup window select user in the user list and make required changes to the 
settings in the General section.
Changes made to the Access level automatically changes the corresponding User Rights.

• To delete a user, simply select it in the user list and click Delete.

NOTE! User will be deleted at once, you will not be asked to confirm.

• When finished click OK to close window.
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Database Management
The default installation of the MAP Check 3 PC software also creates databases needed for the program 
to run properly.
The databases are located in the program installation folder in a sub folder named Database. 

The databases are separated into two files:

Configuration This file contains the program settings, product data, user data and device 
information. It is possible to copy this file to another PC with MAP Check 3 PC 
Software installed to have the same settings (not shared).

Measurements This file contains all measurements captured by the program. This database can be 
selected for location on an existing SQL server if available on the network. This way 
the measurements can be backed up centrally by the SQL server manager.

Using external SQL server
When using external SQL server, you need to enter the following:

• “Server”;  the program browses for servers in the LAN. Select your server.
• “Database”; select the name of the Database on server to use (must be created by server admin),

the program automatically creates needed tables.
• Select authentication method; either “Windows authentication” or enter logon details for server.
You must have login rights to the SQL server. Use “Connection Test” to verify connection. It is ONLY 
measurement data that are stored on SQL server, other settings are stored on PC.

Backup of Databases

NOTE! This should only be done by personnel familiar with Windows PC file copying.

• Close application before proceeding.
• Now use the Windows Explorer to browse to the Database folder in the program installation folder.
• Copy the 2 database files to a safe location on your network for backup purposes.

NOTE! If you have selected an external SQL server in Database settings, you can only 
backup the configuration database manually. The SQL server manager must ensure 
measurements database integrity by regular backups of the server.

Restoring Databases

CAUTION! This should only be done by personnel familiar with Windows PC file copying, as 
wrong operation may lead to data loss.

• Close application before proceeding.
• To restore the database(s), simply copy the database files from your backup location into the 

installation folder's Database folder.
• Restarting the application will load the restored data files.
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Measurement Data
The collection of measurement data can be viewed on the Measurements tab.

All measurement data downloaded from all connected devices is listed here.

Searching Data
With the Search function at the bottom you can search in all fields.

When searching please note the following:

• First select which field to search in from the Search in drop down list, ex. Product.
• Use "*" as wildcard when searching, otherwise you will have to write the exact contents of the field.

When entering ex. "s*" in the search field you will get a list of all products starting with s.
When entering "*s*" in the search field you will get a list of products with an s anywhere in the name.
Please note that the search function is not case sensitive.
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Exporting Data
You can export selected data to a comma separated file (*.csv).

To export data do the following:

1. Select data to be exported from the list and click Export data.
2. The Export logs dialog window appears showing the folder Database which is a sub folder in the 

application installation folder.

3. You can use this folder for your data files or select any other folder of your own choice.
4. Name the file in the File name field.
5. Select export format in the Save as type drop-down list.
6. Click Save.
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Printing Data
To print data do the following:

1. Select data to be printed from the list.

2. Click Print.
3. The Print preview window appears (this might take a few seconds).
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4. In the Columns section you can select which columns to include when printing and with the Print 
Statistics check box below you can select whether or not you want to print the statistics data as 
well.
Selection/deselection of one or more items will automatically update the print preview.

5. Select printer at the top of the window, make required page setup settings and click OK to print.

Statistics
To see a statistical overview of data:

1. If not already displayed, select View -> Show measurements statistics.
Measurement statistics will be displayed at the right side of the window.

2. Select data, ex. Product 2 measurements as shown.
3. The statistics for the selected measurements will be shown, ex. average and minimum and 

maximum values, number and percentage of alarms etc.
The data can be printed by clicking Print – see "Printing Data" on page 27 for details.
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Product Setup
Product setup is performed on the Product list tab. Even though the product database can hold a large 
number of products, only 1000 products can be assigned to each device.

NOTE! When making changes in the product settings, make sure to press "Synchronize" 
in the upper right corner when finished to apply changes to selected device(s).

Create/Edit Product
To create a new product you can either copy and edit one of the existing products or you can create a 
new.

Create new product
• Click New in the lower right corner. A new product appears at the bottom of the product list.
• Edit product settings as described in "Edit product" on page 30.
• When finished click Save to save product. 

Copy product
If you want to create a product similar to an already existing product, you can use the Copy function:

• Select the product you want to copy in the list.
• Click the Copy button.
• A new product with the name xxxxx_copy_1 (xxxxx = name of copied product) appears in the list.
• Name the new product and make the appropriate product settings in the list to the right.
• When finished click Save to save product.
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Edit product
• Select the product you want to edit in the list.
• Make the appropriate product settings in the list to the right.

NOTE! Please refer to the “MAP Check 3 User Guide” for a detailed description of the 
various product parameter settings.

• When finished click Save to save product.

Delete Product
To delete a product from the Product list:

1. First make sure that the product and the product measurements have been removed from the MAP 
Check 3 device, otherwise the product will be downloaded from the device next time when 
synchronizing.

2. Select product and click Delete, then confirm by clicking OK in the appearing dialog box.
3. Synchronize devices to update the respective product lists on the devices.
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Device list
The Device list tab shows an overview of devices which are or previously have been connected to the 
application.

The window shows the name and serial number for each device and the current connection status. The 
device window also holds data for each device such as device info, diagnostics, and calibration 
information.

When a device sensor needs to be calibrated the sensor is highlighted in red. 
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Remove device
To remove a device from the list simply click on the device you wish to remove and then click Delete in 
the window’s lower right corner.
In the appearing Confirm delete window...

...click OK to confirm.

The device will be removed from the various tabs throughout the application but measurements 
performed using the device are maintained on the Measurements tab.
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Remote Data Dump Function
This feature is a separate function that allows you to use the advanced LAN data dump functionality of 
the MAP Check 3 device.

To be able to use this feature, the MAP Check 3 must be configured for the function inside the General 
setup -> Data log setup … menu.

Please refer to the “MAP Check 3 User Guide” for details about setting up of the LAN dump function.

When starting this, the PC software will act as a TCP/IP server which can receive data from multiple MAP 
Check 3 devices and store data in a selected file using the csv file format for easy exchange with other 
applications.

NOTE! The data received from devices is NOT stored in the database of the MAP Check 3 
PC software but only transferred directly to the selected log file.

The window holds data needed to set up the MAP Check 3 devices which should send data to the 
program. You will find the data in the upper part of the window:

Local IP Addresses Holds the IP of the PC running this application. This value must be entered in 
the General Setup -> Data log setup... -> Server IP field on the device.

TCP/IP port Holds the port number to be used. This value must be entered in the General 
Setup -> Data log setup... -> Server Port field on the device.

Ack byte Must match the setting in General Setup -> Data log setup... -> 
Acknowledge (default set to 0 = NOT used).

On the device the setting General Setup -> Data log setup... -> Network logging must be set to Yes. 
This turns on the sending of data after each measurement to the server specified.

In the Log file section select a file name to be used for storing the data received.
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In File creation options select between:

Truncate Opens a new file each time Start is pressed

Append Appends data to the file each time Start is pressed

In History panel the latest received measurements can be seen in clear text, this can be helpful if 
debugging the setup.

Now to start simply press the Start button and the server will run until stopped again by pressing Stop.

Data is captured into the selected file.

This function is similar to that found in programs like e.g. TCP File.

Trouble shooting

NOTE! Windows Firewall might block this function. If you have problems getting data from 
device try to disable the FireWall shortly, if data now appear in history window you should 
add an exclusion for the program in Windows FireWall. Refer to documentation from 
Microsoft on how to do this.

To test if LAN connection is OK between PC and device, you can use the Ping command from your PC:

• Open a command console in Windows and enter the command
ping <IP address of MAP Check 3> <enter>

• Now you should get a TCP reply from the MAP Check 3, see example below.

• If this reply does not appear there is a problem in the LAN connection of either the PC, the device or 
both.

• Re-check your cabling.
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Appendix

End User License Agreement (EULA)

End-user License Agreement for “MAP Check 3 PC Software”

IMPORTANT! Please read the terms and conditions of this license agreement carefully 
before installing the software.

This End-User License Agreement (EULA) is a legal agreement between you (either an individual or a 
single entity) and Dansensor A/S for the Dansensor A/S software product(s) identified above which may 
include associated software components, media, printed materials, and "online" or electronic 
documentation.
By installing, copying, or otherwise using the “MAP Check 3 PC Software”, you agree to be bound by the 
terms of this EULA. This license agreement represents the entire agreement concerning the program 
between you and Dansensor A/S, (referred to as "licenser"), and it supersedes any prior proposal, 
representation, or understanding between the parties.
If you do not agree to the terms of this EULA, do not install or use the "MAP Check 3 PC Software". 

The "MAP Check 3 PC Software" is protected by copyright laws and international copyright treaties, as 
well as other intellectual property laws and treaties.

1. GRANT OF LICENSE
The "MAP Check 3 PC Software" is licensed as follows: 

(a) Installation and Use
Dansensor A/S grants you the right to install and use any number of copies of the "MAP Check 3 PC 
Software" on your computers running a validly licensed copy of the operating system for which the "MAP 
Check 3 PC Software" was designed (e.g. Windows XP or Windows Vista).

(b) Backup Copies
You may also make copies of the "MAP Check 3 PC Software" as may be necessary for backup and 
archival purposes.

2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS
(a) Maintenance of Copyright Notices
You must not remove or alter any copyright notices on any copy of the "MAP Check 3 PC Software".

(b) Distribution
You may not distribute registered copies of the "MAP Check 3 PC Software" to third parties.

(c) Prohibition on Reverse Engineering, Decompilation, and Disassembly
You may not reverse engineer, decompile, or disassemble the "MAP Check 3 PC Software", except and 
only to the extent that such activity is expressly permitted by applicable law notwithstanding this 
limitation. 

(d) Rental
You may not rent, lease, or lend the "MAP Check 3 PC Software".
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(e) Support Services
Dansensor A/S may provide you with support services related to the "MAP Check 3 PC Software" 
("Support Services"). Any supplemental software code provided to you as part of the Support Services 
shall be considered part of the "MAP Check 3 PC Software" and subject to the terms and conditions of 
this EULA. 

(f) Compliance with Applicable Laws
You must comply with all applicable laws regarding use of the "MAP Check 3 PC Software".

3. TERMINATION 
Without prejudice to any other rights, Dansensor A/S may terminate this EULA if you fail to comply with 
the terms and conditions of this EULA. In such event, you must destroy all copies of the "MAP Check 3 PC 
Software" in your possession.

4. COPYRIGHT
All title, including but not limited to copyrights, in and to the "MAP Check 3 PC Software" and any copies 
thereof are owned by Dansensor A/S or its suppliers. All title and intellectual property rights in and to the 
content which may be accessed through use of the "MAP Check 3 PC Software" is the property of the 
respective content owner and may be protected by applicable copyright or other intellectual property 
laws and treaties.
This EULA grants you no rights to use such content. All rights not expressly granted are reserved by 
Dansensor A/S. 

5. NO WARRANTIES
Dansensor A/S expressly disclaims any warranty for the "MAP Check 3 PC Software". The "MAP Check 3 
PC Software" is provided "As Is" without any express or implied warranty of any kind, including but not 
limited to any warranties of merchantability, non infringement, or fitness of a particular purpose. 
Dansensor A/S does not warrant or assume responsibility for the accuracy or completeness of any 
information, text, graphics, links or other items contained within the "MAP Check 3 PC Software". 
Dansensor A/S makes no warranties respecting any harm that may be caused by the transmission of a 
computer virus, worm, time bomb, logic bomb, or other such computer program.
Dansensor A/S further expressly disclaims any warranty or representation to Authorized Users or to any 
third party.

6. LIMITATION OF LIABILITY
In no event shall Dansensor A/S be liable for any damages (including, without limitation, lost profits, 
business interruption, or lost information) rising out of Authorized Users' use of or inability to use the 
"MAP Check 3 PC Software", even if Dansensor A/S has been advised of the possibility of such damages. 
In no event will Dansensor A/S be liable for loss of data or for indirect, special, incidental, consequential 
(including lost profit), or other damages based in contract, tort or otherwise. Dansensor A/S shall have no 
liability with respect to the content of the "MAP Check 3 PC Software" or any part thereof, including but 
not limited to errors or omissions contained therein, libel, infringements of rights of publicity, privacy, 
trademark rights, business interruption, personal injury, loss of privacy, moral rights or the disclosure of 
confidential information.


